# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[(){}]+//g;t' <<< "1,(7287026502032012,18),{(706)},{(101200010)},{(17286)},{(oz)},2.5"