import Foundation
let pattern = #"[(){}]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"1,(7287026502032012,18),{(706)},{(101200010)},{(17286)},{(oz)},2.5"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)