import re
regex = re.compile(r"[(){}]+")
test_str = "1,(7287026502032012,18),{(706)},{(101200010)},{(17286)},{(oz)},2.5"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)