using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[(){}]+";
string substitution = @"";
string input = @"1,(7287026502032012,18),{(706)},{(101200010)},{(17286)},{(oz)},2.5";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}