// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[(){}]+").unwrap();
let string = "1,(7287026502032012,18),{(706)},{(101200010)},{(17286)},{(oz)},2.5";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}