#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[(){}]+"
Local $sString = "1,(7287026502032012,18),{(706)},{(101200010)},{(17286)},{(oz)},2.5"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)