re = /[(){}]+/
str = '1,(7287026502032012,18),{(706)},{(101200010)},{(17286)},{(oz)},2.5'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result