#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "action="(.*?)""
Local $sString = "<html>" & @CRLF & _
"<head>" & @CRLF & _
" <title>new Start</title>" & @CRLF & _
"</head>" & @CRLF & _
"" & @CRLF & _
"<body onLoad="document.forms[0].submit();">" & @CRLF & _
"<form action="http://www.google.com" method="post">" & @CRLF & _
" <input type=hidden name="NUMBER" value="123456">" & @CRLF & _
" <input type=hidden name="mode" value="display">" & @CRLF & _
" </form>" & @CRLF & _
"</body>" & @CRLF & _
"</html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")