// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"action="(.*?)""#).unwrap();
let string = "<html>
<head>
<title>new Start</title>
</head>
<body onLoad=\"document.forms[0].submit();\">
<form action=\"http://www.google.com\" method=\"post\">
<input type=hidden name=\"NUMBER\" value=\"123456\">
<input type=hidden name=\"mode\" value=\"display\">
</form>
</body>
</html>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}