use strict;
my $str = '<html>
<head>
<title>new Start</title>
</head>
<body onLoad="document.forms[0].submit();">
<form action="http://www.google.com" method="post">
<input type=hidden name="NUMBER" value="123456">
<input type=hidden name="mode" value="display">
</form>
</body>
</html>';
my $regex = qr/action="(.*?)"/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}