$re = '/action="(.*?)"/';
$str = '<html>
<head>
<title>new Start</title>
</head>
<body onLoad="document.forms[0].submit();">
<form action="http://www.google.com" method="post">
<input type=hidden name="NUMBER" value="123456">
<input type=hidden name="mode" value="display">
</form>
</body>
</html>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);