import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "action=\"(.*?)\"";
final String string = "<html>\n"
+ "<head>\n"
+ " <title>new Start</title>\n"
+ "</head>\n\n"
+ "<body onLoad=\"document.forms[0].submit();\">\n"
+ "<form action=\"http://www.google.com\" method=\"post\">\n"
+ " <input type=hidden name=\"NUMBER\" value=\"123456\">\n"
+ " <input type=hidden name=\"mode\" value=\"display\">\n"
+ " </form>\n"
+ "</body>\n"
+ "</html>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}