const regex = /action="(.*?)"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('action="(.*?)"', 'g')
const str = `<html>
<head>
<title>new Start</title>
</head>
<body onLoad="document.forms[0].submit();">
<form action="http://www.google.com" method="post">
<input type=hidden name="NUMBER" value="123456">
<input type=hidden name="mode" value="display">
</form>
</body>
</html>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}