import Foundation
let pattern = #"action="(.*?)""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<html>
<head>
<title>new Start</title>
</head>
<body onLoad="document.forms[0].submit();">
<form action="http://www.google.com" method="post">
<input type=hidden name="NUMBER" value="123456">
<input type=hidden name="mode" value="display">
</form>
</body>
</html>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)