#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^[a-zA-ZÀ-ÖØ-öø-ÿ][ '_-a-zA-ZÀ-ÖØ-öø-ÿ]+$"
Local $sString = "Blockquote" & @CRLF & _
"" & @CRLF & _
"João Antonio" & @CRLF & _
"" & @CRLF & _
"João-Antonio" & @CRLF & _
"" & @CRLF & _
"João's Company" & @CRLF & _
"" & @CRLF & _
"Peter Müller" & @CRLF & _
"" & @CRLF & _
"François Hollande" & @CRLF & _
"" & @CRLF & _
"Patrick O'Brian" & @CRLF & _
"" & @CRLF & _
"Silvana Koch-Mehrin" & @CRLF & _
"" & @CRLF & _
"Company N@me" & @CRLF & _
"" & @CRLF & _
"100% Company" & @CRLF & _
"" & @CRLF & _
"\Company" & @CRLF & _
"" & @CRLF & _
"\s Company" & @CRLF & _
"" & @CRLF & _
"_Blockquote" & @CRLF & _
"João Antonio" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")