import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-ZÀ-ÖØ-öø-ÿ][ '_-a-zA-ZÀ-ÖØ-öø-ÿ]+$";
final String string = "Blockquote\n\n"
+ "João Antonio\n\n"
+ "João-Antonio\n\n"
+ "João's Company\n\n"
+ "Peter Müller\n\n"
+ "François Hollande\n\n"
+ "Patrick O'Brian\n\n"
+ "Silvana Koch-Mehrin\n\n"
+ "Company N@me\n\n"
+ "100% Company\n\n"
+ "\\Company\n\n"
+ "\\s Company\n\n"
+ "_Blockquote\n"
+ "João Antonio\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}