using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-ZÀ-ÖØ-öø-ÿ][ '_-a-zA-ZÀ-ÖØ-öø-ÿ]+$";
string input = @"Blockquote
João Antonio
João-Antonio
João's Company
Peter Müller
François Hollande
Patrick O'Brian
Silvana Koch-Mehrin
Company N@me
100% Company
\Company
\s Company
_Blockquote
João Antonio
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}