const regex = /^[a-zA-ZÀ-ÖØ-öø-ÿ][ '_-a-zA-ZÀ-ÖØ-öø-ÿ]+$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-ZÀ-ÖØ-öø-ÿ][ \'_-a-zA-ZÀ-ÖØ-öø-ÿ]+$', 'gmi')
const str = `Blockquote
João Antonio
João-Antonio
João's Company
Peter Müller
François Hollande
Patrick O'Brian
Silvana Koch-Mehrin
Company N@me
100% Company
\\Company
\\s Company
_Blockquote
João Antonio
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}