re = /^[a-zA-ZÀ-ÖØ-öø-ÿ][ '_-a-zA-ZÀ-ÖØ-öø-ÿ]+$/mi
str = 'Blockquote
João Antonio
João-Antonio
João\'s Company
Peter Müller
François Hollande
Patrick O\'Brian
Silvana Koch-Mehrin
Company N@me
100% Company
\\Company
\\s Company
_Blockquote
João Antonio
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end