package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^[a-zA-ZÀ-ÖØ-öø-ÿ][ '_-a-zA-ZÀ-ÖØ-öø-ÿ]+$`)
var str = `Blockquote
João Antonio
João-Antonio
João's Company
Peter Müller
François Hollande
Patrick O'Brian
Silvana Koch-Mehrin
Company N@me
100% Company
\Company
\s Company
_Blockquote
João Antonio
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}