$re = '/^[a-zA-ZÀ-ÖØ-öø-ÿ][ \'_-a-zA-ZÀ-ÖØ-öø-ÿ]+$/mi';
$str = 'Blockquote
João Antonio
João-Antonio
João\'s Company
Peter Müller
François Hollande
Patrick O\'Brian
Silvana Koch-Mehrin
Company N@me
100% Company
\\Company
\\s Company
_Blockquote
João Antonio
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);