use strict;
my $str = 'Blockquote
João Antonio
João-Antonio
João\'s Company
Peter Müller
François Hollande
Patrick O\'Brian
Silvana Koch-Mehrin
Company N@me
100% Company
\\Company
\\s Company
_Blockquote
João Antonio
';
my $regex = qr/^[a-zA-ZÀ-ÖØ-öø-ÿ][ '_-a-zA-ZÀ-ÖØ-öø-ÿ]+$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}