import re
regex = re.compile(r"^[a-zA-ZÀ-ÖØ-öø-ÿ][ '_-a-zA-ZÀ-ÖØ-öø-ÿ]+$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("Blockquote\n\n"
"João Antonio\n\n"
"João-Antonio\n\n"
"João's Company\n\n"
"Peter Müller\n\n"
"François Hollande\n\n"
"Patrick O'Brian\n\n"
"Silvana Koch-Mehrin\n\n"
"Company N@me\n\n"
"100% Company\n\n"
"\\Company\n\n"
"\\s Company\n\n"
"_Blockquote\n"
"João Antonio\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")