# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(grouping\()(?:\([^()]*\)|[^()])*\)/\1foo)/gm;t' <<< "grouping(elllo)
grouping(function() {
console.log(\"hello\")
})"