package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(grouping\()(?:\([^()]*\)|[^()])*\)`)
var str = `grouping(elllo)
grouping(function() {
console.log("hello")
})`
var substitution = "\1foo)"
fmt.Println(re.ReplaceAllString(str, substitution))
}