re = /\b(grouping\()(?:\([^()]*\)|[^()])*\)/m
str = 'grouping(elllo)
grouping(function() {
console.log("hello")
})'
subst = '\\1foo)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result