const regex = /\b(grouping\()(?:\([^()]*\)|[^()])*\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(grouping\\()(?:\\([^()]*\\)|[^()])*\\)', 'gm')
const str = `grouping(elllo)
grouping(function() {
console.log("hello")
})`;
const subst = `\1foo)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);