import Foundation
let pattern = #"\b(grouping\()(?:\([^()]*\)|[^()])*\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
grouping(elllo)
grouping(function() {
console.log("hello")
})
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1foo)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)