$re = '/\b(grouping\()(?:\([^()]*\)|[^()])*\)/m';
$str = 'grouping(elllo)
grouping(function() {
console.log("hello")
})';
$subst = "\1foo)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;