use strict;
my $str = 'grouping(elllo)
grouping(function() {
console.log("hello")
})';
my $regex = qr/\b(grouping\()(?:\([^()]*\)|[^()])*\)/mp;
my $subst = '\\1foo)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";