#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b(grouping\()(?:\([^()]*\)|[^()])*\)"
Local $sString = "grouping(elllo)" & @CRLF & _
"" & @CRLF & _
"grouping(function() {" & @CRLF & _
" console.log("hello")" & @CRLF & _
"})"
Local $sSubst = "\1foo)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)