# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/http:\\/\\/www\.\w+\.com/<a href="$0">$0<\/a>/gm;t' <<< "This is a test, with http://www.example.com and more stuff...
another one is http://www.test.com oh yes"