use strict;
my $str = 'This is a test, with http://www.example.com and more stuff...
another one is http://www.test.com oh yes';
my $regex = qr/http:\/\/www\.\w+\.com/mp;
my $subst = '<a href="$0">$0</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";