using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"http:\/\/www\.\w+\.com";
string substitution = @"<a href=""$0"">$0</a>";
string input = @"This is a test, with http://www.example.com and more stuff...
another one is http://www.test.com oh yes";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}