import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "http:\\/\\/www\\.\\w+\\.com";
final String string = "This is a test, with http://www.example.com and more stuff...\n\n"
+ "another one is http://www.test.com oh yes";
final String subst = "<a href=\"$0\">$0</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}