const regex = /http:\/\/www\.\w+\.com/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('http:\\\/\\\/www\\.\\w+\\.com', 'gm')
const str = `This is a test, with http://www.example.com and more stuff...
another one is http://www.test.com oh yes`;
const subst = `<a href="$0">$0</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);