// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)http:\/\/www\.\w+\.com").unwrap();
let string = "This is a test, with http://www.example.com and more stuff...
another one is http://www.test.com oh yes";
let substitution = "<a href=\"$0\">$0</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}