#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)http:\/\/www\.\w+\.com"
Local $sString = "This is a test, with http://www.example.com and more stuff..." & @CRLF & _
"" & @CRLF & _
"another one is http://www.test.com oh yes"
Local $sSubst = "<a href="$0">$0</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)