package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)http:\/\/www\.\w+\.com`)
var str = `This is a test, with http://www.example.com and more stuff...
another one is http://www.test.com oh yes`
var substitution = "<a href="$0">$0</a>"
fmt.Println(re.ReplaceAllString(str, substitution))
}