re = /http:\/\/www\.\w+\.com/m
str = 'This is a test, with http://www.example.com and more stuff...
another one is http://www.test.com oh yes'
subst = '<a href="$0">$0</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result