package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"rel1_out": $'(.+?)$`,`)
var str = `"load_nom": 3192,
"rel1_out": "0",
"pump_pwm": 0,
"temp1": 500,
"temp2": null,`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}