// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""rel1_out": $'(.+?)$`,"#).unwrap();
let string = "\"load_nom\": 3192,
\"rel1_out\": \"0\",
\"pump_pwm\": 0,
\"temp1\": 500,
\"temp2\": null,";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}