use strict;
my $str = '"load_nom": 3192,
"rel1_out": "0",
"pump_pwm": 0,
"temp1": 500,
"temp2": null,';
my $regex = qr/"rel1_out": $'(.+?)$`,/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}