import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"rel1_out\": $'(.+?)$`,";
final String string = "\"load_nom\": 3192,\n"
+ " \"rel1_out\": \"0\",\n"
+ " \"pump_pwm\": 0,\n"
+ " \"temp1\": 500,\n"
+ " \"temp2\": null,";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}