const regex = /"rel1_out": $'(.+?)$`,/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"rel1_out": $\'(.+?)$`,', '')
const str = `"load_nom": 3192,
"rel1_out": "0",
"pump_pwm": 0,
"temp1": 500,
"temp2": null,`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}