# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?|(?=\b(?:[a-z]*[A-Z]){1})(\w)|(?!^)\G(\w)(?!\b))/\1 /g;t' <<< "It's a simple SEnTeNCE with a FEW word."