use strict;
my $str = 'It\'s a simple SEnTeNCE with a FEW word.';
my $regex = qr/(?|(?=\b(?:[a-z]*[A-Z]){1})(\w)|(?!^)\G(\w)(?!\b))/p;
my $subst = '\\1 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";