import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?|(?=\\b(?:[a-z]*[A-Z]){1})(\\w)|(?!^)\\G(\\w)(?!\\b))";
final String string = "It's a simple SEnTeNCE with a FEW word.";
final String subst = "\\1 ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}