const regex = /(?|(?=\b(?:[a-z]*[A-Z]){1})(\w)|(?!^)\G(\w)(?!\b))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?|(?=\\b(?:[a-z]*[A-Z]){1})(\\w)|(?!^)\\G(\\w)(?!\\b))', 'g')
const str = `It's a simple SEnTeNCE with a FEW word.`;
const subst = `\1 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);