re = /(?|(?=\b(?:[a-z]*[A-Z]){1})(\w)|(?!^)\G(\w)(?!\b))/
str = 'It\'s a simple SEnTeNCE with a FEW word.'
subst = '\\1 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result